[ X ]
Bugs
Post any bugs you find here
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. Goto page 1, 2  »
View previous topic :: View next topic  
Author Message
Sleipnir
Level: 150



Position: Administrator
Joined: 10 Apr 2002
Posts: 4135
Kel: 3645  [ Donate ]

Online Status: Offline
PostPosted: Sat Mar 04, 2006 3:23 am    Post subject: Bugs Reply with quote

I've done my best to find and fix as many bugs as possible before release, but nobody is perfect, so if you find anything that doesn't work properly then post it here.

Fixed Bugs:
  • New Post icon missing in Spaced Out theme
  • All users appear to be 136 years old
  • 'New posts since last visit' search showing topics from hidden forums
  • Modifying 'Registration info' perminantly deactivates account
  • Some members not appearing on memberlist after changing page
  • PM \' and quote bbcode bugs


Last edited by Sleipnir on Sun Mar 12, 2006 1:42 am; edited 1 time in total
Back to top
View user's profile Find all posts by Sleipnir Send private message Send e-mail Visit poster's website ICQ Number
Sleipnir
Level: 150



Position: Administrator
Joined: 10 Apr 2002
Posts: 4135
Kel: 3645  [ Donate ]

Online Status: Offline
PostPosted: Sun Mar 12, 2006 1:40 am  Reply with quote

I've deleted all the posts regarding bugs that have been fixed, just to tidy things up a bit.

Today i fixed the following bugs:
  • If you modified any information on the 'Registration info' page it would deactivate your account with no way to reactivate it.
    The following accounts were affected by the issue and have been re-enabled:
    • Andre27
    • The_Hunter
    • |Zenas|
    • TypeProton

  • Some members not appearing on memberlist after changing page
  • PM \' and quote bbcode bugs
Back to top
View user's profile Find all posts by Sleipnir Send private message Send e-mail Visit poster's website ICQ Number
The_Hunter
Cameo Lord
Level: 112



Position: Registered User
Joined: 23 Jan 2004
Posts: 1766
Kel: 272

Online Status: Offline
PostPosted: Wed Mar 15, 2006 4:35 pm  Reply with quote

if i try edit my post shortly after posting it and then submiting it says that i can't post so fast after having posted
_________________
http://shockwave.swr-productions.com/Avatars_Sigs/swr_sig.png
Back to top
View user's profile Find all posts by The_Hunter Send private message Visit poster's website MSN Messenger ICQ Number
thyob
Level: 103



Position: Registered User
Joined: 09 Sep 2003
Posts: 357
Kel: 20  [ Donate ]

Online Status: Offline
PostPosted: Sat Mar 25, 2006 2:16 pm  Reply with quote

When trying to send a private message I got Template->make_filename(): Error - template file not found: ttg/message_body.tpl
_________________
http://www.thyob.com/thyobsig.png
Back to top
View user's profile Find all posts by thyob Send private message Visit poster's website AIM Address MSN Messenger ICQ Number
Sleipnir
Level: 150



Position: Administrator
Joined: 10 Apr 2002
Posts: 4135
Kel: 3645  [ Donate ]

Online Status: Offline
PostPosted: Sat Mar 25, 2006 2:24 pm  Reply with quote

Fixed
Back to top
View user's profile Find all posts by Sleipnir Send private message Send e-mail Visit poster's website ICQ Number
Methis
Blessed are we without a god.
Level: 107



Position: Registered User
Joined: 23 Jan 2004
Posts: 1171
Kel: 320  [ Donate ]

Online Status: Offline
PostPosted: Sat Mar 25, 2006 6:15 pm  Reply with quote

I reckon it's probably not a bug, but I do wonder: Why is the Spellcheck disabled? Or has just not been ported/coded yet?
_________________
http://i2.photobucket.com/albums/y34/Me-is-this/TPH666White.png
Back to top
View user's profile Find all posts by Methis Send private message Visit poster's website AIM Address MSN Messenger ICQ Number
Sleipnir
Level: 150



Position: Administrator
Joined: 10 Apr 2002
Posts: 4135
Kel: 3645  [ Donate ]

Online Status: Offline
PostPosted: Sat Mar 25, 2006 11:03 pm  Reply with quote

The code works fine, the problem is that the server SS is hosted on doesn't have a piece of software installed that is needed for it to work.
Back to top
View user's profile Find all posts by Sleipnir Send private message Send e-mail Visit poster's website ICQ Number
Methis
Blessed are we without a god.
Level: 107



Position: Registered User
Joined: 23 Jan 2004
Posts: 1171
Kel: 320  [ Donate ]

Online Status: Offline
PostPosted: Sun Mar 26, 2006 4:18 am  Reply with quote

Ah, I see. Any idea when it's coming back?
_________________
http://i2.photobucket.com/albums/y34/Me-is-this/TPH666White.png
Back to top
View user's profile Find all posts by Methis Send private message Visit poster's website AIM Address MSN Messenger ICQ Number
Suiseiseki
Carnivean
Level: 120



Position: Registered User
Joined: 22 Jun 2002
Posts: 2279
Kel: 216  [ Donate ]

Online Status: Offline
PostPosted: Sat Apr 15, 2006 10:51 am  Reply with quote

Changing password seems to claim to deactivate your account but doesn't make it inactive while sending an email with just '?mode=activate&u=xxx&act_key=' in it.
_________________
http://twistedmalice.co.uk/stuff2/logob.png
Back to top
View user's profile Find all posts by Suiseiseki Send private message MSN Messenger ICQ Number
Detail
David
Level: 111



Position: Registered User
Joined: 11 Apr 2002
Posts: 1162
Kel: 176  [ Donate ]

Online Status: Offline
PostPosted: Sun Jun 11, 2006 11:13 am  Reply with quote

Links are red. Under everyones avatar is a bit of red text saying "registered". Every other bit of red text is a link, thus the pattern suggest that this bit of red text will also be a link... but it's not!
_________________
dayonic.com
Back to top
View user's profile Find all posts by Detail Send private message Visit poster's website MSN Messenger ICQ Number
Methis
Blessed are we without a god.
Level: 107



Position: Registered User
Joined: 23 Jan 2004
Posts: 1171
Kel: 320  [ Donate ]

Online Status: Offline
PostPosted: Sun Jun 11, 2006 1:33 pm  Reply with quote

Detail wrote (View Post):
Links are red. Under everyones avatar is a bit of red text saying "registered". Every other bit of red text is a link, thus the pattern suggest that this bit of red text will also be a link... but it's not!


Then again.. there is no red text to be deceptive? Razz
I'm pretty sure this has to do with the theme used. i.e. I use Spaced Out and don't get red text.. "Registered user" shows up as blue, like most things. The only red I get on here is from the "Offline" status thingy -_-

_________________
http://i2.photobucket.com/albums/y34/Me-is-this/TPH666White.png
Back to top
View user's profile Find all posts by Methis Send private message Visit poster's website AIM Address MSN Messenger ICQ Number
Sleipnir
Level: 150



Position: Administrator
Joined: 10 Apr 2002
Posts: 4135
Kel: 3645  [ Donate ]

Online Status: Offline
PostPosted: Sun Jun 11, 2006 1:49 pm  Reply with quote

The "Registered User" text is globally defined per theme, so it will be the same colour nomatter where in the forum you look (although it will differ depending on the theme you use).
Its just coincidence (well, more of a convention) that the colour of the registered users in the "who is online" section is the same as the regular link colour in the default themes...

I don't really see it as an issue, as eventually it will be a link, going to the memberlist displaying all the users in that group.
Back to top
View user's profile Find all posts by Sleipnir Send private message Send e-mail Visit poster's website ICQ Number
Methis
Blessed are we without a god.
Level: 107



Position: Registered User
Joined: 23 Jan 2004
Posts: 1171
Kel: 320  [ Donate ]

Online Status: Offline
PostPosted: Sat Sep 15, 2007 1:10 pm  Reply with quote

I was trying a few things out when I came across the following:
In Firefox, if you create a custom theme by combining Red'n'Black as the main theme with Mindblank buttons, all the links/buttons at the top (Knowledge Base, Downloads, Search, UCP etc.) disappear. Inconvenient. I also noticed that with most combinations, only the buttons remain (e.g. just the question mark button for the Knowledge Base, without any text).
Not sure if these are (known about) bugs, but I think it'd be nice to change it nevertheless..

_________________
http://i2.photobucket.com/albums/y34/Me-is-this/TPH666White.png
Back to top
View user's profile Find all posts by Methis Send private message Visit poster's website AIM Address MSN Messenger ICQ Number
Sleipnir
Level: 150



Position: Administrator
Joined: 10 Apr 2002
Posts: 4135
Kel: 3645  [ Donate ]

Online Status: Offline
PostPosted: Sun Sep 16, 2007 12:44 am  Reply with quote

That's not really a bug, more of a consequence of how the two themes work.

By default, the template includes both the button image and the text links. The Mindblank theme has a css rule in it's image stylesheet to hide the (non-existant) button images, whereas the Red'n'Black theme hides the text links in its main stylesheet as the text is included in the buttons.You just happened to choose the only combination of stylesheets that will cause both rules to be applied at once.

There's an easy workaround - create a custom stylesheet based off the Red'n'Black main stylesheet, and remove the following:
Code:

/* Hide the menu text */
.mainmenu span {display: none;}
Back to top
View user's profile Find all posts by Sleipnir Send private message Send e-mail Visit poster's website ICQ Number
BobingAbout
Level: 107



Position: Registered User
Joined: 14 Aug 2002
Posts: 579
Kel: 213  [ Donate ]

Online Status: Offline
PostPosted: Mon Sep 17, 2007 8:13 am  Reply with quote

I have a bug!!!
i no longer seem to be able to access this site via my ISP...
:ManfredVonKarmaHeadbang:

_________________
The Director is Master, The Director is Master, Hey, Why am I saying that?
The Revolution : Retaliation of the Civillians
http://www.sleipnirstuff.com/forum/files/colonalscampikraven.gifhttp://www.sleipnirstuff.com/forum/files/kraven.gif
http://www.sleipnirstuff.com/forum/files/rrotc.gif
Back to top
View user's profile Find all posts by BobingAbout Send private message Visit poster's website MSN Messenger ICQ Number
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. Goto page 1, 2  »